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OVERVIEW 
This data modeling techni ecise method for detailing and illuminating the 
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ou are
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objects of an application an
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diagram (ERD). The data model (ERD) shows the major data 
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ntities and the composition of the data attributes of the entities in 
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orking with the Repository Functions.) The defined components 
our ERD diagram by selecting these options from the View menu.  

A
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uding different combinations of entities and relationships on 
r, the entire data model, including the data elements composing 
he repository and can be accessed by creating a global view of 
 explained in this lesson. 
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Entity   The entity (or, more properly, the entity type) is nothing more th

a real-world object that you want to describe. The most generic 
type of entity is really a fundamental or independent entity, but is
usually simply called an entity. It is composed of data elements 
(also called attributes), and you can describe these in the entity’s 
repository composition field. A fundamental entity is an object or 
event. It is represented on an entity relationship diagram as a 
rectangle and is accessed by the first symbol button on the control
bar. 
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Associative Entity  

e relationship between a customer 
and a product produces as a by-product the associative entity 

 on 

 
Attributive Entity   

on the existence of a  
fundamental entity. It is also used to show repeating subgroups of  

s  

 
Relationship  

 two 
The relationship lines can have 

rminators that show that the entities relate to each other on a one-
to-one, one-to-many, or many-to-many basis (the relationship’s 
cardinality), and whether the relationship is optional or mandatory.  
There are four line buttons on the control bar.  Line types may be 
changed after they are drawn on the diagram. 

 
Supertype/Subtypes Specialized subtype entities can be created that are based on a  

generalized supertype entity and share common attributes. Only 
the attributes unique to the specialized entity need to be listed in 
the subtype entity. This is closely related to the object class 
inheritance concept.  Visible Analyst also provides a detail field 
for specifying the exact number of relationships, if known.  The 
supertype/subtype button is the fifth line button on the control bar. 

 
Cluster   A cluster is a collection of entities and the relationships between  

them. It is not truly a part of your data model because it carries no 
 information. However, it can be very useful when you want to 

ave it 

Another type is the associative entity (sometimes called a  
junction, intersection or concatenated entity, a gerund or a 
correlation table). This is basically a relationship (see below) about 
which you want to store information. It can only exist between two 
other entities. For example, th

purchase order. A purchase order entity would not exist without 
the relationship between the other two entities. An associative 
entity is represented as a rectangle with straight diagonal lines 
across each corner. It is accessed by the second symbol button
the control bar. 

The third entity type is the attributive or dependent entity. This is 
used to show data that is wholly dependent up

data. For example, the associative entity purchase order may have  
a dependent attributive entity named shipment showing the full or  
partial shipments that fulfill the purchase order. It is represented a
a rectangle with rounded lines across each corner and is accessed  
by the last symbol button on the control bar. 

A relationship shows how one entity interacts with or can be  
affiliated with another entity. It appears on a diagram as a line 
drawn between two entities. Relationship lines ordinarily have
labels, one for each direction. 
te

new
show very large data models on a single diagram and still h

 94 



Entity Relationship Diagrams 
 

comprehensible. You have the ability to cluster groups of entities 
m in 

sitory and entities are added to its 
 

er 

Visible Analyst generates is an unstructured diagram, but the 
ram pertains to your entity 
nformation on Clusters, see the 

ect 
iew.  

d define the join 
relationships, clauses and flags to be used by the view.   For more 

n on view objects, see the Operation Manual or the 

 
                             Figure 7 Entity Relationship Diagramming Symbols 

and show these clusters and the relationships between the
summary fashion on a diagram. This limits the amount of detail on 
the diagram so that the larger outlines of what is contained in your 
data model are more visible. 

 
A cluster is created in the repo
composition field. A cluster view can then be created by Visible
Analyst  to display the pseudo-relationships between clusters rath
than real relationships between specific entities. The diagram 

information contained in the diag
relationship diagrams. For more i
Operation Manual or the online help system. 

 
View Object  A view object can be thought of as a derived or virtual table.  It is  

composed of two components:  a list of column names and a sel
statement used to filter information from the tables in the v
For each view, there is one primary select clause and any number 
of sub-select and union select clauses.  Using the Define View 
dialog box, you select the tables and columns an

informatio
online help. (View objects are not available in the Education 
Editions of Visible Analyst.) 
 

-1  
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Relationship Cardinalit
sible Analyst supports four differ

rowsfoot, Arrow, and Bachman. Th  select it 
n a new project is creat . The  choice. 

ou can indicate one or tw ames per 
Crowsfoot notation with tw names

notation is IDEF1X.  You ld th
cardinality notation. 

DEVELOPING YOUR DATA MODEL 
Each entity relationship diagram is complete in and of itself and shows one view of the data 
model of your project. (Remember that a view is a portion or subset of your entire data model 
represented on a single diagram.) When beginning your data model, you must manually add 
new entities and relationships to a view diagram. After this has been done, you can create 
additional views by using the File menu View function to select existing entities and 
relationships from the repository.  Visible Analyst automatically draws the views for you. 
Then you can add to or subtract from each view and rearrange it as you wish. Thus you avoid 
having to draw portions of your data model repeatedly on different views. 

Adding Entities to a View 
Since the basic building block of the data model is the entity type (or simply, the entity) and 
since relationships cannot exist except to relate already existing entities, you begin by adding 
entities to a view. 
 
Set the Zoom Level: 1 From the View menu, select 66% zoom so that you can  

see all of your needed workspace. 

reate a New Diagram: 2 . 

. 

4 Select the Page Size to be Standard. 

 

y 
ent relationship cardinality notations:  IDEF1X, Vi

C e type of notation you use is up to you, and you
ed number of names per relationship line is also yourwhe

Y o n relationship. For this lesson, we use the standard 
o  per relationship. 

 
If you select IDEF1X as the relationship cardinality when creating the project, the default 

wou en select Crowsfoot, Arrow or Bachman as an alternate 

 
C From the File menu, select New Diagram
 

3 Select the diagram type to be Entity Relationship with 
standard drawing method

 

 
5 Click OK. 

 
Add Entities:  6 Click the first symbol icon, the rectangle. This is a  

fundamental entity. 
  

 96 



Entity Relationship Diagrams 
 

7 Place the cursor in the middle of the diagram workspace 
and click the left mo ttuse bu on. An entity is drawn. 

 
 Add another fundamental entity below the first, and name 

10 , 

 
                   Figure 7-2  New Entities 
 
Save the Diagram: 11 From the File menu, choose Save and name the diagram  

“Driving School View.” 
 

Changing a Symbol Type 
In the diagram we have created, the entity Driving Lessons is actually an attributive entity 
because the entity exists solely because it is an attribute of the fundamental entity Driving 

chool. Since we placed it on the diagram as a fundamental entity, it is necessary to change 
e symbol type. 

 
8 Name the entity “Student Driver” and click OK. 

9
it “Driving School.” 

     
Add another fundamental entity below Driving School
and name it “Driving Lessons.” 

S
th
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S
Ch

elect Symbol to   1 Put the cursor in selection mode by clicking the  button  
ange:    on the control bar.  

k the symbol labeled Driving Lessons with the right 

 
  to Global  

hange in the Change Object dialog box. This option is  

ery 
, 

l 

 
4 Select nge Type. 

 
5 ve Entity and click OK. 

bol 
ram. 

 
                  Figure 7-3  Changed Entity Type 
 

    
2 Clic

mouse button so that its Object menu appears. 

Change the  3 Select Change Item.  The Scope must be set
Entity Type:  c

important when you change an object’s type or label. 
Selecting Global causes the change to be made on ev
diagram where that object occurs. If you select Individual
the change is only made to the selected object. A Loca
change would modify all occurrences on the current 
diagram. All changes to a symbol type must be Global. 

Cha

Select Attributi
 
6 Click OK on the Change Object dialog box. The sym

is changed on the diag
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Adding Relationship Lines  
We need to establish the relationships between the entities on the current diagram. 
 
Draw the   1 Click the first line button on the control bar. 
Relationship:    

2 Draw a line from Driving School to Student Driver. The  
procedure is the same as that used to draw a line in 
Lesson 5 -  Diagramming. Click and hold the left mouse 
button where you want the line to begin, drag the line 
to where you want it to end. If you release the button 
within the symbol, the line is connected automatically.  If 
not, you must double-click the left mouse button to end 
the line.  
 
 Note 

 When you use an elbow line and the elbow in the line does not bend in the 
direction that you want it to, click the right mouse button while you are still 
holding the left one, and the elbow inverts. 

 
 
Label the   3 Enter “Instructs” for the label of the first relationship.  To  
Relationship:   set the relationship cardinality, click One for the  

Minimum, and click Many for the Maximum. This means 
that “Driving School instructs one or many Student 
Drivers.”  If you know the exact maximum number of 

etail box. (See relationships, you can enter it in the d
Figure 7-4.) 
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          Figure 7-4  Label Relationship Dialog Box 

 
      

4 

 
5 

ilities of the Analyze function.) It means  a “Student 

t is 
t driver, 

 

Press the TAB key to move the cursor to the next field or 
click the mouse in the other label field. 

Enter “Attends” for the reverse relationship name. For the 
Minimum click One, and for the Maximum click Many. 
(This deliberate error is added to demonstrate the 
capab
Driver attends one to many Driving School.” Both of 

ause ithese relationships are considered mandatory bec
necessary to attend driving school to be a studen
and it is necessary to have students to be a driving school. 
Ensure that Type is set to Normal, and click OK. 
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Draw Another    Draw a line from Driving School to Driving Lessons.  For  

ro  

Provided By.” Because this is an Identifying relationship, 
the cardinality is automatically set to 1:1. Click OK. 
 

 Save:    7 Press CTRL+S to save the diagram. 
  

Analyzing the Diagram 
The Analyze function checks to ensure that the diagram is syntactically correct, meaning that 
all relationship lines and symbols are labeled. You can also use the Analyze function to check 
for certain normalization errors. 
 
Start Analyze:  1 Select Analyze from the Diagram menu. 
 

2 Choose Current Diagram and Syntax Check.  Click OK.  
It tells you that the current diagram is correct. 

 
Insert an Error:  3 Add a symbol to the diagram without naming it. 
 
Analyze Again:  4 Run Analyze again.  You see an error message  

indicating that there is one unnamed entity. Click Cancel 
to return to the diagram. The unnamed entity can be 
deleted from the diagram by highlighting it with the 

nd pressing Delete. 

lyze Still Again: 5 Run Analyze again, but this time choose Normalization.  
onship “Driving 
 normalized. This 

ror 

nship Attends,  
t button. 

 

 

6
Relationship:   the first label, type “Offers,” and set Minimum to Ze

and Maximum to Many. For the second label, type  “Are 

cursor in selection mode a
 
Ana

You see the error message that the relati
School [Instructs] Student Driver” is not
is true. The error indicates that the cardinality is 0:many 
or many:many in both directions. It is flagged as an er
because optional:optional and many:many relationships 
can be difficult to implement. Click Cancel to close the 
box. 

 
Correct Cardinality  6 To change the cardinality of the relatio
Error:    click the relationship line with the righ

7 Select Change Item. Change the cardinality for Attends 
from a maximum of Many to a maximum of One.  
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8 Click OK. 
 

Ana e 
 correct. 

 

 
                                          Figure 7-5  Normalized Diagram 
 

Automatically Generating a View of Your Data Model 
Another very useful feature of Visible Analyst is the ability to generate new data model views 
automatically. Since a data model can become very large and sometimes very difficult to 
decipher with many relationship lines and symbols, generating a specific view of the data 
model allows you to focus on one portion of your data model without having to redraw all of 
the symbols and connections that you want to have on the diagram. The function for 
generating a view is found on the View of Data Model submenu from the File menu. 
 
There are three different options for generating a view from this function. 

• There is an option to generate a global view of your data model. All of the entities 
and relationships that are in the repository are placed on one diagram. This feature is 
important when additions are made to one portion of the data model and you would 

lyz Once More: 9 Select Analyze from the Diagram menu. Choose  
Normalization and click OK. The diagram is now
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like to see how those changes have affected the entire model. Another use for this 
feature is to generate an entity relationship diagram for imported entity information. 

nerate a new vi
already created on a diagra
relationships you would li
additions or changes to yo
portion. 

is Process. A process 
 of your data model and 

is based upon a p ess ex
elements that ente r leav
contained in the c positi e process 
view, along with ween pairs of entities. A process view 
allows you to con on of your data model that is involved 
with the selected process. This is the type of view that you now create. The 
composition information for the entities that appeared, as well as the attribute 
information of the particular process, has already been entered for you in the sample 
diagrams we supp ed. This is so that you do not have to enter the information 
necessary to dem strate this feature of Visible Analyst. 

o create the pro

tart View Generation: 1 Select View of Data Model from the File menu, then  
choose Process.  The Select Process for Views dialog  
box appears. 
 
 

• You can ge ew, allowing you to choose from the entities you have 
m or in the repository those entities and attached 

ke displayed on a new diagram. This allows you to make 
ur entire data model while concentrating on only one 

• The other view option from the View of Data Model option 
view is an entity relationship diagram that represents a subset

roc isting on a data flow diagram or in the repository. Data 
r o e the selected process in data flows and that are also 

on of entities cause those entities to appear in thom
the relationships existing bet
centrate on the specific porti

li
on

 
cess view: T

 
S
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                                            Figure 7-6  Process View Dialog Box 
 

elect the Process: 2 Click the process Issue License and click OK. Visible 
for entities that contain 

e data flows that are 
attached to Issue License and creates a “View” of the data 
model. 

 
Save the New View: 3 Select Save from the File menu. 
 

4 Title the diagram “Process View: Issue License.”  This 
diagram is a subset of your entire data model. 

 
5 Click OK. 

 
 
 
 

 
 

                     
 
 
 
 
 
 

Analyst searches the repository 
data elements in common with th

S
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                                      Figure 7-7  The Generated Process View 




